Can not get midi guitar to reconize the guitar. Microphone is turned on for midi.

I can not get Midi Guitar to reconize my guitar. I have turned on the microphone in Midi but to no avail, any suggestions?

1 person likes this idea

Are you seeing movement in the Noisegate?

Make sure all other apps are closed. Midi guitar is CPU hungry, so you need as much memory as you can muster. Also, other apps may be blocking mic permissions. 

What I always do before I plug the cable into the iPhone is first open Sampletank. Once it's loaded I open Midi Guitar 2 and make sure I see movement on the noise gate.

From there, I'll set the Midi output route to Sampletank or Virtual Midi and then I'll finally connect the cable. From there it should work and you can go back to sample tank to use the midi patches.  

Every once in awhile, I'll have to close restart Midi Guitar because it will do exactly what you're describing. If this is persistent, Try deleting and reinstalling Midi Guitar. 

If you need more help, submit a support ticket and I'll reach out to you. 



Thanks Dave.  I had the same problem as Jimmy just yesterday.  I had recently updated my Iphone 6 software and I was beginning to wonder if that was the source of my problems.  You gave a couple suggestions here that I will try.  Hopefully, that will solve the issue and it;s not because of the Iphone software.  

I ran into the same situation as Jimmy just last night.  I went through the steps as suggested above to troubleshoot the problem, and the step that worked for me was to delete and reload Midi Guitar 2.  I suspect that a recent Iphone software update may have triggered something with Midi Guitar 2 to cause the problem, but what do I know...  Anyway the problem was solved.  Thanks for the help Dave.  Hope you get yours working Jimmy.  

As luck would have it, it happened to me after updating to 11.2.6. 

A quick delete and reinstall fixed it though. Midi Guitar 2 is an amazing app, but there are some issues with it. 

Hopefully, over time, they will get them addressed and corrected. 

Login or Signup to post a comment